Basic steps for updating Spectrum files in 2024 estimation round
Generalized and Concentrated HIV epidemics – 26 January 2024, UNAIDS

As you complete each step below, please document all changes using the “Source” button in the Spectrum and EPP modules and the “Changes” menu item in AIM. This documentation will provide other members of your estimates team, UNAIDS, and other potential users with important information about how the file was developed. 

Start by creating a copy of your previous 2023 file and reviewing the demographic data
1. Download and install the latest Spectrum version from http://www.avenirhealth.org/Download/Spectrum/.
2. Open your final 2023 file in Spectrum. Contact estimates@unaids.org if you need your final 2023 Spectrum file. For countries with an ADR account, you will need to log in to your ADR account. If you get a message that Java is not installed, exit and install Java before saving the file under a new name. Give your file a new name (e.g. Country_01Jan2024) in the File menu, below the Spectrum icon in the upper left-hand corner and select Save as.  
3. For national files, ensure the population data was read from WPP 2022: select Manager > Default data, check DemProj, then click OK. Select DemProj>Results to review and check the accuracy of total fertility rates, births and total population. If needed, visit https://www.un.org/development/desa/pd/content/World-Population-Prospects-2022  to review data, sources and methods used. The WPP 2022 estimates are de facto populations (all current residents irrespective of nationality) and include mortality due to COVID.
4. Ensure the end-year for the projection is set to 2030. 

Update Program Statistics data: PMTCT, ANC testing, ART, testing, and viral suppression
5. PMTCT: Review and update program data up to 2023. Ensure that the projected coverage from 2024-2030, entered as percentage, is realistic relative to Spectrum-estimated coverage over 2020-2023. Use the Plot button to check for potential errors in the data. 
If data are not available from your country, use global default assumptions of retention at delivery: 80% for both women already on treatment and those starting during this pregnancy. Use the default monthly drop-out rates from postnatal prophylaxis of 1.2% in the first year and 0.7% for 12+ subsequent months of breastfeeding. 
For countries with generalized epidemics, click on breastfeeding patterns and Read household survey data. This will update breastfeeding patterns among women not on ARVs.

6. ANC testing: Update data on testing, retesting, known and new HIV outcomes among pregnant women and, optionally, program-registered births. Identify and resolve any possible errors in these detailed data (see Guide for updating Spectrum HIV estimates, Step 5) before entering the corresponding prevalence and denominator (both should include women known to be living with HIV before first ANC visit) in EPP.  
7. Child and adult treatment: Enter numbers of people currently on treatment, for all years since start of the ART program up to 2023. 
You may record and use results of ART data quality assessments, in the form of a correction factor to adjust program data for under- or over-count, by calendar year, in the lower right of the Child treatment and Adult ART data entry tabs. You can enable or disable this adjustment. Every time you change adult ART numbers or the adjustment, please refit the EPP or CSAVR incidence curve, which depends on them.
8. For each year with a non-0 number of people receiving ART, enter an annual treatment interruption rate. This can be based on nation-wide or nationally representative program data. Optionally extrapolate this rate to years before and after existing data. If you have no reliable data, enter a default rate for all years: 5% in all countries (except 1.6% in high-income countries) – for both adults and children. Fill annual numbers initiating and re-initiating ART, if available, which will be used in validation charts of HIV testing and treatment cascades. 
9. ART by age: Please enter the number on ART by 5-year age group (or, if not available, by broad GAM age group) and sex for all available years.
10. Viral suppression: Update numbers of people tested for viral load and, among those tested, the number suppressed. If the viral load testing threshold differs from 1000 copies/mL, enter the detection threshold of the assay. Spectrum will automatically adjust to numbers expected to be suppressed at the standard threshold of 1000 copies/mL (in rows below your data) and with those, in Results produce a standardized HIV testing and treatment cascade comparable with other countries. 
11. For Generalized epidemics using one national Spectrum file, import national Key Populations data (prevalence, population size estimates and ART coverage), after updating the Key Populations Excel workbook. This will not affect the Spectrum national estimates, but will initiate data review prepare for future country estimates of new infections by sub-population.

Set Advanced options 
12. Update the Advanced Options to ensure there are no outdated, non-default values—which will show in red font. You may need to Restore Default Values on four screens: Paediatric Transition Parameters, Adult Transition Parameters, HIV related fertility, and Allocation method for New ART patients. Notably countries in AP, LA and CAR regions should adopt the new On-ART mortality defaults.

13. Update the assumed effect of ART on HIV transmission, based on the updated Viral Load Suppression data entered, under Adult Transition Parameters > HIV mortality with ART > Calculate ART effect. 

Choose the incidence estimation method
14. By default, Spectrum will use the incidence method used last year. If you want to change the method for the 2024 round, select the new incidence estimation fitting methodology under Incidence Options, choosing one of: Direct incidence input, EPP, AEM, CSAVR or ECDC model.

15. Follow the steps below if you use EPP.
A. Review the epidemic configuration (important in case of demography/population changes)
· Select Incidence > Configuration (EPP) on the main AIM screen. 
Activate ‘Prevalence adjustment’ and set the ‘Maximum adjustment factor’ to the global default of 10.
You will get a notice asking if you want to review or refit your incidence curves. You should refit the curves.
· Verify the epidemic structure is the one desired. 
· If you changed the demography (in DemProj module or in Projection Manager), in the Define pops page, extrapolate the distribution up to 2030, by selecting either “Adjust for changed pop” or “Adjust to UN Values” to modify the distribution based on the updated population data. 
· Concentrated epidemics will redistribute the new total population by subpopulations using existing proportional distributions previously entered. If there are new subpopulation size estimates, change the estimate for the year in which the estimate was made and use the interpolation feature for  interim years since the last estimate. 
For concentrated epidemics: In the % Male & Turnover tab, verify that percentages male and turnover rates are consistent with any new data. Save and continue.

B. Update surveillance and survey data
· Select Incidence > Surveillance data (EPP) in the main AIM menu.
· On the HIV Data tab of EPP, add any new surveillance and/or routine ANC data (prevalence and sample size) after careful review. For any routine program data (ANC and other testing services, including for Key Populations), be sure to include ‘known positives’ who were not retested, into both the numerator and denominator; otherwise you will underestimate prevalence.
· For Generalized epidemics: On the Surveys page, ART coverage data from representative surveys can be added using the Import surveys function. If you trust the survey’s ART coverage, activate its use in EPP curve fitting by clicking ‘Use ART in fitting’. This will help ensure regional fits reflect the distribution of ART in the country and its impact on prevalence, incidence and mortality in each region.
· The ART Distribution tab distributes adults on ART across the sub-populations or sub-regions. Generalized epidemic countries can import 2023 Naomi regional estimates -- preloaded in EPP if these matched the EPP configuration; this updates the ART distribution tab with Naomi values. Concentrated epidemic (and other non-Naomi) countries should review and update this table against available programme data.
· On the Surveys tab of EPP, enter data from nationally representative population surveys only. For concentrated epidemics, surveys on Key Populations are rarely national and typically better dealt with in EPP’s Surveillance page; consult your UNAIDS advisor if still entering KP surveys in the Survey page.
· Concentrated epidemics with substantial numbers of new infections among immigrants or overseas workers returning, or an outbreak in a medical setting, can use the External HIV tab (discuss with your facilitator first): Review your data for these "External" infections, estimate their number for each year, and allocate them among the different groups. These will affect EPP’s fitting: the external infections add to onward HIV transmission from the year in which they are introduced. 
· Save and continue.

C. Fit incidence curves (EPP)
· Select Incidence > Curve fitting (EPP) in the main AIM menu.
· On the “Project” tab of EPP under “Model”, select R-Hybrid (default for generalized epidemics) or the appropriate alternative model. See the Guide for updating Spectrum HIV estimates (Step 7) for how to choose a statistical model, in turn for each sub-population. 
· To move between sub-populations, either click on “Save and continue” to move to the next sub-population, or click on the sub-population under “National Epidemic Structure” at the right of the screen). 
· For Concentrated epidemics, UNAIDS guidance has been updated to try R-Hybrid as default even for sub-populations with few data points; please see Guide for updating a Spectrum HIV estimation, Figure 1.
· Run “Fit All”. Once fitting is complete for all sub-populations, click “Save All”. Wait until EPP completes saving all sub-populations.
· Review resulting curves and compare them against surveillance data. If the fit is implausible, explore other models or consider adding prevalence conditions under “Model Parameters” and refit. See caveats about prevalence conditions in Guide for updating Spectrum HIV estimates, Step 10).
· Click on the “Calibration” tab of EPP and scale the curve up or down, for each sub-population. For concentrated epidemics, review the impact of this calibration by clicking on “Calibration Table”, review the M/F prevalence ratio against any available data. For generalized epidemics with household surveys there is no need to use the calibration page. 
· Document any adjustments made on the “Calibration” tab, after exiting this tab, under the “Source” button next to the “Help” button.
· In “Fitting Results”, compare the new results against last year’s curve by clicking “Compare”  and “Load” in the Comparison window. Use the file chooser to locate and select the previous year’s PJNZ file. Review both the national curves and each set of sub-population curves. Make notes in the “Source” button of the “Fitting Results” tab to explain differences.
· Before exiting EPP, be sure to click “Save Results”  which allows AIM to access the just completed curve fits.

16. Follow the steps below if you use CSAVR.
A. Update new case diagnoses, HIV/AIDS deaths and (optionally) CD4 at diagnosis data
· Select Incidence > Fit incidence to CSAVR > Enter/edit data
· Enter new case diagnoses for the latest year for adults 15 years and older, by age and sex if available These should include any first-time diagnoses among immigrants. In contrast, immigrant PLHIV diagnosed abroad before entry into the country, should instead be entered into AIM > Incidence > HIV+ migrants by age. 

· Enter or update AIDS-related deaths from Vital Registration. We recommend that you use deaths adjusted for incomplete reporting and misclassifications in causes of death, compiled by the IHME for the GBD 2020. 
Countries classified as 2C in IHME’s 2019 GBD, with poor completeness and/or quality of vital registration, should not enter (or at least not fit) death data in CSAVR.
Using the Source 1/2/3 button under ‘Data, both sexes’, you may enter both adjusted and unadjusted AIDS deaths, and optionally as a third series a ‘hybrid’ of both (IHME-adjusted data for years available, original Vital Registration for other years). Optionally, fit CSAVR to each mortality dataset in turn (renaming and saving the file for each different mortality source) to compare the resulting incidence estimates and select the most plausible one. 

· Optionally, enter available data on CD4 counts at diagnosis (stratified in 4 categories) for years that covered at least 80-95% of all adults newly diagnosed and are believed to be representative of all new diagnoses.

· Ensure that the data tables do not include 0s for years where data are missing altogether (as CSAVR would read these as zero cases or deaths). By contrast, for years with cases and/or deaths for either sex or some but not all age groups, put 0 for the sex and age groups with 0 recorded counts – to enable CSAVR to fit the reported sex/age distribution. 
Click “OK” to save your data updates.

B. Fit incidence curves
· Select Incidence > CSAVR > Fit Incidence. 
· Review the data you entered in the panel graphs (red diamonds). Examine outliers and correct if needed, returning to Incidence > Fit incidence to CSAVR > Enter/edit data.
· Back in > Fit incidence, select the indicators to include in the fit (cases, deaths and optionally CD4-at-diagnosis), including all high-quality data. 
· Select the type of statistical model (Double logistic, Single logistic, Splines with 3, 4 or 5 knots, or rLogistic). 
· If you entered case diagnoses and/or deaths with sex and/or age disaggregation, for all models (in turn) activate ‘Adjust IRRs during fitting’ for sex and/or age. This option will not show if your data missed sex and age. 
· Set all models (or at least) to either “Training run” – which runs quickest, but does not produce uncertainty bounds – or National run. Run all 4-6 models in turn using the ‘Fit selected model’ button, or all at once using the ‘Fit all models’ button; 
for Splines run at least the 5 knots and optionally (if none of the earlier 4 models looks sensible) also try 3 or 4 knots.
· To select the best model, consider the respective Akaike Information Criterion scores (bottom-left corner). Lower AIC number indicates better fit, but if AIC values differ by less than 10 between 2 models, either is acceptable. Before deciding, also review the Model comparison graphs, preferring curves with plausible smooth historic patterns in new infections, HIV population and knowledge of status. In Model comparison graphs, the selected model shows as a blue line, the other 3 models show in green shades. Colours switch as you change the selected model. 

C. Review outputs, revise model or data used in the fitting and accept results
· On CSAVR’s Validation page, review the fits to case diagnoses and AIDS deaths, as well as estimated number of PLHIV and proportion who know their HIV status, by sex. 
· If results are acceptable, click OK. Otherwise, select a different set of indicators to fit to (e.g. de-activate CD4 data), a different statistical model, or revise data in Enter/edit data and refit.
· Back in ‘Model fitting’, confirm your selected model, and if not yet done, rerun it using “National run”. 
· Review CSAVR results a final time and then click OK to save the selected incidence curve. 

Update the sex/age pattern and HIV-related fertility reduction in AIM
17. [bookmark: _Hlk119496735]Generalized epidemics: If you have a survey with HIV seroprevalence, in AIM under Sex/Age pattern select Fit Incidence ratios > Pattern fitted to HIV prevalence or ART, choose HIV prevalence and the most recent survey. Fit the incidence ratios: first, using Fixed incidence ratios, and then using Time-dependent ratios. Compare the two fits to the survey data. Choose the fit with the lowest AIC. Select OK.

Concentrated epidemics: 
· If using EPP-Concentrated epidemics or AEM incidence, select Read sex ratio from EPP or AEM. 
· If using CSAVR, select Pattern from CSAVR, so AIM will use the same age and sex IRRs as CSAVR.
· For EPP-Concentrated and AEM incidence models, if you entered ART data by 5-year age group into ‘ART by age’ under Program Statistics, refine the age pattern in incidence accordingly, by clicking Pattern fitted to HIV prevalence or ART > Fit incidence ratios. 

18. Adjust fertility and prevalence in pregnant women to national routine ANC data, by importing those data under Advanced Options > HIV-related fertility reductions > Fit local adjustment factor, your updated ANC data ‘From program data’, then Fit Fertility rate Ratios. 

19. On the Knowledge of Status tab, estimate and read Knowledge of Status from Shiny90 or CSAVR into AIM
· If using the Shiny90 model: Access the link to the Shiny90 app using the button on the tab, run Shiny90 and read its results into Spectrum. 
· If using CSAVR: Select CSAVR  and ‘Load’ its updated knowledge of status estimate, for all years for adults by sex. 
· Other countries: Enter any estimates of PLHIV who know their status for all years available manually – based on cumulative new diagnoses minus all cumulative deaths and emigrations of diagnosed PLHIV. 
· For children (not estimated by Shiny90 or CASVR), use program-data-based knowledge of status if you can subtract all deaths and emigrations, as well as children surviving & ageing into the 15+ years cohort. If this is not possible or does not produce a result consistent with Spectrum-estimated children living with HIV, have Spectrum calculate child Knowledge of Status (KOS) for all years, based on the entered numbers on ART and treatment interruption rate. 

View Results and Validate
Save the file once back (from EPP or CSAVR) in Spectrum AIM (File > Save Projection).

20. View results – otherwise the file will not be re-projected. Notably review ART > Treatment cascade, to ensure a coherent cascade with ≤100% of PLHIV knowing their status, ≤100% of known PLHIV on treatment and <100% of treated virally suppressed, for men, women and children in turn, all years. 
Save the reprojected file.

21. Validate Spectrum-estimated results by comparing them with additional data entered on the Validation tab, for:

· Prevalence and ART coverage by sex and age relative to national household surveys; 
· ART waterfall of the change in adult and child ART numbers between 2022 and 2023, considering new initiations, re-initiations, treatment interruptions and Spectrum-estimated deaths.
· ART coverage from program versus ANC data: adult ART coverage estimated by Spectrum from program data compared with a prediction based on the proportion of HIV-positive pregnant women already on ART at the time of their first ANC visit, as entered under Program statistics > PMTCT. This validation is recommended for countries in sub-Saharan Africa. If the prediction and the program-based estimate are not close, it may indicate problems with one of the sources.

· Concentrated and mature epidemics with high ART coverage fitted by CSAVR, ECDC or an external model may validate the Spectrum estimate for all-cause mortality (beyond the AIDS-attributed) among those on ART; as well as all-cause mortality to all people (PLHIV and uninfected) and AIDS mortality. 

22. Compare results to your previous year’s file (open your previous year file in Spectrum using the Read-Only command). 

Run uncertainty analysis and check file completeness
23. On the Validation tab, click Check File Completeness to ensure that all the above steps have been completed. 
Address any issues that are labelled as False.

24. Run the uncertainty analysis by choosing the Tools tab at the top of the screen, then More Tools and AIM: Uncertainty Analysis, then click Process. Keep the default ‘300’ for “Number of iterations” and change the year to ‘2023’ for “Aggregate data capture year”. When done press Save. Back in AIM, you will now see uncertainty bounds on graphs and tables in the Results tab. 

25. Save the file a final time and send it to estimates@unaids.org  ﷟
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