Basic steps for updating Spectrum files in 2022
Concentrated epidemic countries, version 22 December 2021
As you complete each step below, please document all changes using the “Source” button in the
Spectrum and EPP modules and the “Changes” menu item in AIM. This documentation will provide
other members of your estimates team, UNAIDS, and other potential users with important information
about how the file was developed.

Get started by creating a copy of your previous 2021 file and updating
demographics
1. Download and install Spectrum from http://www.avenirhealth.org/Download/Spectrum/ Be sure to
download the latest version under AIM Releases
2. Open your final 2021 Spectrum file using the Spectrum software. Contact estimates@unaids.org if
you need your final 2021 Spectrum file. Give your file a new name (e.g. Country_2022) by clicking on
the File menu below the Spectrum icon in the upper left-hand corner and select Save as. Caution:
Do not copy, paste then rename your projection file in Windows Explorer.
3. Review the population data. Select DemProj >Results to review and check the accuracy of the total
fertility rate and the total population. If needed, visit UN Population Division
(http://esa.un.org/unpd/wpp/DataSources/ ) to see the sources used to create World Population
Prospects 2019 data used for most countries.
Update program data (PMTCT, ANC, ART, testing and viral suppression)
4. Review and add PMTCT data for 2021 by selecting the Program statistics tab. Ensure that the
projected coverage from 2022-2025 is realistic for these indicators. Use the Plot button to check
for potential errors in the data.
On the PMTCT tab, if data are not available from your country, use the global default
assumptions of retention at delivery of 80% for both women already on treatment and those
starting during this pregnancy. Use the default monthly drop-out rates from postnatal
prophylaxis of 1.2% in the first year and 0.7% for 12+ subsequent months of breastfeeding.
On the PMTCT tab, for countries with generalized epidemics, click on breastfeeding patterns and
read the survey data. This will update breastfeeding patterns among women not on ARVs to
reflect breastfeeding in this group. For concentrated epidemics review the data to make sure
they match available information and are realistic.
5. On the ANC testing tab, enter data on retesting and HIV outcomes and update data on testing
among pregnant women for 2021. Identify and resolve any possible errors in the ANC data
before using those data in EPP. Note that these data are intended to help resolve errors in your
data and are not used in the model.
6. On the child and adult treatment tabs, enter data on the number currently on treatment,
number initiating and among those, the number reinitiating for as many years as are available.
Review the percent lost to follow up rates, which will be used in the disaggregated HIV testing
and treatment cascades. If data are only available for a few years review the Quick Start manual
to get additional guidance on how to handle these data.
If there were major disruptions in services because of COVID these can be reflected in monthly
cells on the right-hand side of the screen. If no data are available, leave those cells blank.
7. ART by age for adults: please enter the number on ART by either 5-year age group or the GAM
age disaggregation and by sex for all available years. These data are not used in the model but
can be used to evaluate Spectrum ART coverage estimates by age group, in the Validation tab of
AIM.
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8.

On the viral load suppression tab, update the numbers tested and among those the number
suppressed. If the viral load testing threshold is different than 1000 copies/mL, enter in the
detection threshold of the assay. Spectrum will automatically adjust for the numbers expected
to be suppressed at the recommended 1000 copies/mL and the results will be visible as a
separate category in Results in the disaggregated HIV testing and treatment cascade. Currently
the viral suppression data are used to calculate your progress toward the testing and treatment
targets (95-95-95) but are not used in the model.

Set Advanced options
9. Update the Advanced Options pages to ensure there are no unexpected red values. The values
in red font identify values that are not default values. You will need to select Restore Default
Values on four screens: the Paediatric Transition Parameters, Adult Transition Parameters, HIV
related fertility, and Allocation method for New ART patients.
10. For countries that use ANC routine data in EPP, you can scale the fertility adjustment to match
the prevalence from antenatal clinics by selecting Fit local adjustment factor, then Read ANCRT census data from EPP, then Fit Fertility rate Ratios. Note that this should be done after you
have entered your latest ANC-RT surveillance data under Incidence > Surveillance.
Choose the incidence estimation method
11. By default, Spectrum will use the incidence method used last year. If you want to change the
method for the 2022 round, pick the new incidence estimation method under Incidence
Options. (From the ‘Select incidence fitting methodology’ choose one of: Direct incidence input,
EPP, AEM, or CSAVR. Click OK)
12. Follow the steps below if you are using EPP.
A. Update the epidemic configuration
 Select Incidence > Configuration (EPP) on the main AIM screen. You will get a notice
asking if you want to review or refit your incidence curves. You should refit the curves.
 Verify the epidemic structure is the one desired.
 In the Define pops page, select either “Adjust for changed pop” or “Adjust to UN
Values” to modify the distribution based on any updated population data. Concentrated
epidemics will be updated to reflect the same proportional distribution previously
entered. If there are new population size estimates, change the estimate for the year in
which the estimate was made and use the interpolation feature for the interim years
since the last estimate. Also extrapolate the estimate through 2025.
For concentrated epidemics: Choose the % Male & Turnover tab. Verify that the % male
and turnover rates are consistent with any newly available data. Save and continue.
B. Update surveillance and survey data
 Select Incidence > Surveillance data (EPP) in the main AIM menu
 On the HIV Data tab of EPP, add any new surveillance or routine ANC data (prevalence
and sample size) after careful review of the data. For concentrated epidemics using
routine program data, be sure to add the ‘known positives’, into both the numerator
and denominator; otherwise you would underestimate prevalence.
 If you are adding ANC routine data for the first time, click the ANC data type. Two rows
will appear under each site in the table. Review the criteria for using ANC routine testing
data before using this function (see Spectrum Quick start guide).
 NEW! for Generalized epidemics: On the Surveys page, ART coverage data can be added
using the Import surveys function if you had a survey that measured this indicator. If
you trust the survey’s ART coverage, activate it’s use in EPP curve fitting by clicking ‘Use
ART in fitting’. This new information element will help improve regional fits to reflect
the distribution of ART in the country and its impact on prevalence, incidence and
mortality.
 NEW! A new ART Distribution tab will automatically distribute the adults on ART across
the sub-populations or sub-regions. Review this table against data that can inform this
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distribution and modify as needed. Countries that used the Naomi model in 2021 can
import last year’s Naomi regional estimates, which have been preloaded in EPP.
 For concentrated epidemics: On the Surveys tab of EPP, only data from nationally
representative population surveys should be entered; these are rarely available for
specific key populations.
 Concentrated epidemics with a substantial number of current infections among
returning migrants or overseas workers can use the External HIV tab (discuss with your
facilitator first): Review your data for these "external" infections, estimate their number
for each year, and allocate them among the different groups. Then for each group, fill
the estimated number of external infections in each year. These will affect your fits, as
the immigrant infections will add HIV transmission during that year in EPP’s calculations
of incidence.
 Save and continue.
C. Fit an incidence curve (EPP)
 Select Incidence > Curve fitting (EPP) in the main AIM menu.
 On the “Project” tab of EPP under “Model”, select R-Hybrid or the appropriate model.
This needs to be done for each sub-population (to change sub-populations, click on the
sub-population under “National Epidemic Structure” at the right of the screen). See the
QuickStart guide for how to choose a model.
 For the ‘Purpose of run’ choose “National projection”.
 Run “Fit All”. Once fitting is complete for all sub-populations (this may take some time),
click “Save All”. Wait until EPP completes saving each sub-population.
 Review resulting curves and compare them against surveillance data, add any
prevalence conditions under “Model Parameters” if needed and refit as required.
 Click on the “Calibration” tab of EPP and calibrate your sub-populations as appropriate.
For concentrated epidemics, review the impact of this calibration by clicking on the
“Calibration Table” button and carefully review the sex ratio against any available data.
For generalized epidemics, no change is needed.
 Note any adjustments made on the “Calibration” tab with the “Source” button next to
the “Help” button.
 On the “Fitting Results” tab compare the new results against last year’s curve by clicking
on the “Compare” button and then the “Load” button in the Comparison window. Use
the file chooser to locate and select the previous year’s PJNZ file. Review both the
national curves and each set of sub-population curves. Make notes in the “Source”
button of the “Fitting Results” tab to explain differences.
 “Save Results” (which allows Spectrum to access the new curve fits) and exit EPP.
13. Follow the steps below if you are using CSAVR
A. In AIM, update incidence rate ratios if needed – Before entering or updating programme
data, please complete step 14 below (choosing sex/age pattern).
B. Enter or revise CSAVR data
 Select Incidence > Fit incidence to CSAVR > Enter/edit data
 Enter case diagnoses data for the latest year for adults 15 years and older, by age and
sex if available. Optionally, also enter any data on CD4 counts at diagnosis (stratified in 4
categories) if available and judged of good quality, covering all adults newly diagnosed
or a representative majority of them.
 Enter or update HIV-related deaths. We recommend that you use HIV deaths with
adjustment for incomplete reporting and misclassifications in cause of death, compiled
by the IHME, at https://cod.unaids.org or
https://shiny.dide.imperial.ac.uk/csavr_mortality/ and in a CSV file prepared by UNAIDS
that you can import into CSAVR using “Read data from .csv” option. Caution: Reading-in
the CSV file will replace all earlier entered death data in this table.
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Only countries classified as 2B or 2C in IHME’s 2019 GBD, i.e. with poor completeness
and/or quality of Vital Registration, should not enter death data into CSAVR.
 NEW! If you have good-quality data on CD4 count at diagnosis, for a (representative)
majority of new cases, and you wish to use these in fitting (complementing or
substituting deaths), also enter these —in the 4 categories of CD4 count.
 If a large number of new adult diagnoses were among immigrants, enter these, by age,
sex and calendar year, under Incidence > Fit incidence to CSAVR > New diagnoses
among in-migrants’.
 Check that the tables do not include 0s for years where data are missing, as these would
be fit as zero cases or deaths, as opposed to missing. Click “OK”.
C. Review data entered and fit an incidence curve
 Select Incidence > CSAVR > Fit Incidence
 Review the data you have entered, in the panel graphics (red diamonds). Examine
outliers and correct if needed.
 Select data that will be included in the fit (cases, and deaths and/or CD4-at-diagnosis),
including all high-quality data initially.
 Select the type of model (Double logistic, Single logistic, Splines or rLogistic). As default,
the model selected shows as the one that was selected in the previous year’s final
estimate.
 Select “Training run” – which will run quicker (than National run) and allow you to find
the best model with the lowest Akaike information criterion.
 Click on the “Fit model” button.
D. Review outputs, revise model or data used in the fitting and accept results
 On the model fitting tab, review the fits of the Optimizer (blue lines) to the data (red
diamonds). Click on the Validation page to see the fits to case diagnoses and HIV deaths
by sex, as well as for the estimated number of PLHIV and proportion who know their HIV
status.
 If results are acceptable, click OK. Otherwise, select a different set of data to fit to (e.g.
de-activate CD4 data) or a different model and refit incidence. The AIC value in the
bottom left corner can be used to compare model fits. The lowest number indicates the
best fit. If the difference in AIC values between 2 models is smaller than 10, either
model is acceptable. On the model comparison tab, you can compare results from
different incidence models.
 If the fits to sex-specific diagnoses or deaths are not good, the “Adjust IRRs during
fitting” option can be activated on the Model Fitting tab and then each model refit.
Choose to adjust the IRRs to either age, or sex, or both. With these adding parameters,
fitting may be slower, but the fitting result equal or better (i.e. lower AIC value).
 When the best fitting model has been selected, select “National run” under the
“Purpose of Fit” heading and then refit the model.
 Review the results a final time and then click OK to save the incidence curve.
Review the sex/age pattern for the incidence and refit
14. NEW! For generalized epidemics: Under Sex/Age pattern. If you have a survey with HIV
seroprevalence, select Fit Incidence ratios, choose HIV prevalence and the most recent survey.
Fit the incidence ratios: first, using Fixed incidence ratios, and then using Time-dependent
ratios. Compare the two fits to the survey data. Choose the fit with the lowest AIC. Select OK.
For concentrated epidemics using EPP concentrated epidemics incidence, select Read sex ratio
from EPP. If you entered age- and sex-specific data into the ‘ART by age’ tab under Program
Statistics, you can use those data to estimate the sex and age pattern of incidence.
NEW! If you fitted incidence using CSAVR, in AIM Sex/Age pattern, select Pattern from CSAVR,
so AIM will use those same IRRs estimated by CSAVR.
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View the results
Save the file once you are back in Spectrum (File > Save Projection)
15. View results – be sure to do this step otherwise the file will not be re-projected within
Spectrum. After you are satisfied with your projection, view the AIDS impact results (such as
deaths and infections averted). This will take a few minutes to produce these variables. Save
results.
16. Validate the results by comparing results to external data on the validation tab.
17. Compare the results to your previous year’s file (open your previous year file in Spectrum using
the Read Only command).
If available for your country, Run Knowledge of status estimates using Shiny90 tool
18. On the Knowledge of status tab, for countries using the Shiny90 model, access the link to the
Shiny 90 App using the button on the tab, run the model and then read the results into
Spectrum. For countries using estimates from CSAVR, select the CSAVR option and import the
data. This will update estimates for all years for adults 15 years and older by sex. For other
countries, enter in the 2021 data. If knowledge of status is not available for children, use the
number on ART as a conservative estimate.
Run uncertainty and check the file completeness
19. Process the uncertainty analysis by choosing the Tools tab at the top of the screen and then
choosing More Tools and AIM: Uncertainty Analysis, then click Process. Keep the defaults ‘300’
for “Number of iterations” and ‘2021’ for “Aggregate data capture year”. When done press
Save. You will then see the uncertainty bounds when you view results in the Results tab.
20. NEW! Under the Validation tab is a new button to help review the file. Click on Check File
Completeness to see that all the above steps have been taken. Address any issues that are
labelled as False.
21. Save the file a final time and send it to estimates@unaids.org
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